Last Updated on September 25, 2021 by Admin 1

300-410 : Implementing Cisco Enterprise Advanced Routing and Services (ENARSI) : Part 07

  1. An OSPF area contains the following networks:165.164.8.0 255.255.254.0

    165.164.10.0 255.255.254.0

    165.164.12.0 255.255.254.0

    165.164.14.0 255.255.254.0

    How can the route to these networks be summarized?

    • 165.164.8.0 255.255.240.0
    • 165.164.8.0 255.255.248.0
    • 165.164.10.0 255.255.252.0
    • 165.164.14.0 255.255.240.0
    Explanation:
    Summarization is the process of advertising a network with a subnet mask such that it includes all of the subnets. For a simple example if you had two Class C networks, you could advertise them as a Class B network and it would encompass them both. Normally summarization should be implemented such that it summarizes ONLY the networks desired and no others (in the simple example it would possibly include other Class C networks). The process for arriving at the “best” summarization is a follows.

    First, write the last octet that all networks share in common (third octet in this case) in binary form for each network:

    165.164.8.0–00001000
    165.164.10.0–00001010
    165.164.12.0–00001100
    165.164.14.0–00001110

    The addresses have the first five bits in common; therefore, they can be summarized with the third octet 00001000 and a subnet mask of 255.255.248.0.

    Another way of looking at it is that 165.164.8.0 255.255.248.0 covers the range of 165.164.8.0 through 165.164.15.255, the same range as all the component subnets.

    None of the following possible answers is a valid range, nor do most of them cover the correct range of addresses:

    165.164.8.0 255.255.240.0 is not a valid range. A 20-bit mask can only be on a subnet that is a multiple of 16, such as .16.0, .32.0, .48.0 etc. The subnet .8.0 is not a multiple of 16.

    165.164.10.0 255.255.252.0 is not valid. A 22-bit mask requires a multiple of 4 in the third octet, and 10 is not a multiple of four. Even if it were a valid range, it does not cover the entire range of addresses that need to be summarized.

    165.164.14.0 255.255.240.0 is not valid. The 20-bit mask is only usable on ranges that are multiples of 16 in the third octet, and 14 is not a multiple of 16. Even if the mask were valid, it could not cover the correct addresses.

    When addresses are summarized the cost of the summary address will the highest cost of the component subnets. For example, in the partial sample output of the show ip route command below, there are three routes. The output is from a router running OSPFv3, so the addresses are IPv6, but the concept is the same.

    OI 2001:0D B 8:0:0:7/64 [110/20]
    via FE 80::A8BB:CCFF:FE 00:6F00, FastEthernet0/0
    OI 2001:0D B 8:0:0:8/64 [110/100]
    via FE 80::A8BB:CCFF:FE 00:6F00, FastEthernet0/0
    OI 2001:0D B 8:0:0:9/64 [110/40]
    via FE 80::A8BB:CCFF:FE 00:6F00, FastEthernet0/0

    The routes have metrics (the second value in brackets, [administrative distance/cost]) of 20, 100, and 40. Therefore, the metric for the summarized route would be 100.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify manual and autosummarization with any routing protocol

  2. You have implemented OSPF for IPv6 for the following areas in OSPF AS 1:

    300-410 Part 07 Q02 083
    300-410 Part 07 Q02 083

    The cost from rtrB to the 2001:5050:D402:B333:1:FE30::/96 network is 80, while the cost from rtrB to the 2001:5050:D402:B333:2:FE59::/96 network is 130.

    Which of the following area range cost commands should be executed on rtrB?

    • area 10 range 2001:5050:D402:B333::/64 cost 80
    • area 10 range 2001:5050:D402:B333::/64 cost 130
    • area 10 range 2001:5050:D402:B333::/64 cost 210
    • area 10 range 2001:5050:D402:B333::/64 cost 0
    Explanation:
    The area 10 range 2001:5050:D402:B333::/64 cost 130 command should be executed on rtrB. This command defines an area range for an area border router (ABR) that has OSPF for IPv6 enabled on it. This command provides a summary route of the routes in an OSPF area to be distributed to another area.

    The range keyword in the command provides the summary route. The cost keyword in the command specifies the cost of the summary route. The highest cost of the routes that are being summarized becomes the cost of the summary route. In this case, the cost from rtrB to the 2001:5050:D402:B333:1:FE30::/96 network is 80, and the cost from rtrB to the 2001:5050:D402:B333:2:FE59::/96 network is 130. The cost of the summary route is 130 as it is higher.

    All the other options are incorrect because they do not specify the correct cost of the summary route.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify OSPF for IPv6

  3. You are using an aggregate static route to null 0 to redistribute static routes into BGP.

    Which problem can result if the router loses access to one of these routes?

    • Black hole
    • Routing loop
    • Split horizon
    • Unstable BGP table
    Explanation:
    If one of the aggregated routes is lost, the router will discard packets destined for that route. This condition is known as a black hole.

    For example, suppose you have a number of subnets of range 11.1.0.0/16, all of which have 24 bit masks, such as 11.1.2.0/24. You aggregate them all to 11.1.0.0/16 and advertise that aggregate. If this router were to lose connectivity to one of the subnets, for example 11.1.3.0/24, then any traffic routed through this router to that subnet would never reach it, even if there were another valid path.

    Split horizon is a loop avoidance mechanism that is by default always in effect, and is not affected by the loss of a subnet route that is part of an aggregate route.

    BGP tables are not made unstable by the loss of the loss of a subnet route that is part of an aggregate route.

    Routing loops would not occur simply from the loss of a subnet route that is part of an aggregate route.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify manual and autosummarization with any routing protocol

  4. You have configured BGP on both rtrA in AS 1 and rtrB in AS 2. There are two routes created using the network command between the two routers. One route traverses through AS 5 and AS 6 from rtrA to rtrB, while the other route traverses AS 7, AS 8, and AS 9 from rtrA to rtrB. Both routes use default values for the Weight and LOCAL_PREF attributes.

    Which of the following attributes determines the BEST route between rtrA and rtrB routers?

    • Weight
    • LOCAL_PREF
    • Origin type
    • AS_PATH
    Explanation:
    The AS_PATH attribute is used to determine the best path between the two routes. To select the best path from rtrA to rtrB, BGP analyzes attributes that are set for the two available routes during the configuration of the network. The key BGP attributes and the order in which they are checked are as follows:
    Weight – highest weight is selected
    LOCAL_PREF – highest LOCAL_PREF is selected
    Locally originated routes – local routes are selected
    AS_PATH – shortest AS_PATH is selected
    Origin type – lowest origin type is selected
    Multi-exit Discriminator (MED) – lowest MED is selected

    The weight attribute is the first attribute to be checked while selecting the best BGP route. This attribute is relevant only to the local router on which it is set. The value of this attribute can be any number from 0 to 65535. The default values are 32768 for locally originated routes and 0 for other types of routes. Both routes in this case are originated locally and have the default weight values. Therefore, in this case, the weight attribute is not used to determine the best route.

    BGP then checks the value of the LOCAL_PREF attribute, which refers to local preference. Local preference is a value indicates the route that is preferred to exit the AS to reach a given network. Routes with higher local preference are selected by BGP. You can set the local preference for a route to any value; however, if you do not, the route uses the default value of 100. Because both routes have the default LOCAL_PREF value, this attribute is not used to determine the best route.

    Next BGP checks whether any of the routes are locally originated using the network, redistribute, or aggregate commands. As stated, both routes originated using the network command on the routers. Consequently, BGP analyzes the value of the AS_PATH attribute, which is a list of the AS numbers traversed by a particular route. The route with the shortest AS_PATH is selected as the best path. In this case, the route that consists of AS 5 and 6 is considered the best path because the AS_PATH value for this route is shorter than that for the route traversing AS 7, 8, and 9. The AS_PATH value for the route traversing AS 5 and 6 is [6 5 1], while the AS_PATH for the route traversing AS 7, 8, and 9 is [9 8 7 1].

    The other options are incorrect because the corresponding attributes are same for both the routes; hence, those attributes are not considered while BGP determines the best path.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Explain BGP attributes and best-path selection

  5. Examine the exhibit.

    300-410 Part 07 Q05 084
    300-410 Part 07 Q05 084

    Router R2 has been configured with the following OSPF router command:

    area 1 range 130.31.96.0 255.255.224.0

    Which addresses listed will be summarized by R2 into area 0? (Choose all that apply.)

    • 130.31.128.0/23
    • 130.31.112.0/20
    • 130.31.130.0/24
    • 130.31.160.0/22
    • 130.31.104.0/21
    Explanation:
    The command area 1 range130.31.96.0 255.255.224.0 is used to summarize the IP network addresses from 130.31.96.0/24 to 130.31.127.0/24 in area 1. Addresses 130.31.112.0/20 and 130.31.104.0/21 are both in that range of network addresses.

    To determine if an address is a part of a summary, put the summary address and summary mask in binary format. Do the same with the address and the summary mask you are examining, as shown below:

    130.31.96.0      10000010.00001111.01100000.00000000
    130.31.112.0     10000010.00001111.01110000.00000000
    255.255.224.0   11111111.11111111.11100000.00000000

    If the address you are testing and the summary address agree to the point where the mask stops, then the test address is part of the summary. In this case, they agree through the 27th bit, so this address is a part of the summary. The same is true for the 130.31.104.0 address.

    In OSPF, you can only configure summarization on the border routers. The summaries need to be of routes within a single area. You summarize the routes of an area so that routers in another area do not see the individual networks, just the summary. The correct command is:

    area area id range ip-address mask

    The area id parameter is the number of the area whose networks are being summarized. For example, in the network shown in the exhibit, to summarize the networks within area 1 to 130.31.96.0/19 you would configure router R2 with the command area 1 range 130.31.96.0 255.255.224.0. This would not affect the routing tables of the routers within area 1, but instead make the routing tables of areas 0 and 2 smaller. These other routers would only have the summary route listed instead of the individual networks. Router 3 would only see the summary route 130.31.96.0/19.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify manual and autosummarization with any routing protocol

  6. When an EIGRP router starts, it sends a hello packet out of all interfaces.

    Which type of packet do neighboring routers send in response?

    • ACK
    • Hello
    • Query
    • Reply
    • Update
    Explanation:
    When an EIGRP router starts, it sends hello packets out of each interface. Neighboring routers respond with update packets. These update packets are sent reliably, and must be acknowledged with an ACK packet from the EIGRP router.

    EIGRP makes neighbor relationships simple. If a router hears a hello from a new neighbor, it sends that neighbor updates for all routes that it knows. This is different from Open Shortest Path First (OSPF), which has a complex series of rules governing how neighbor relationships are formed and how databases are synchronized. When changes to the network occur in OSPF, updates packets route reliable change information only to the affected routes.

    Queries and replies in EIGRP only occur when a router loses a route to a network and is actively seeking a replacement route.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Describe EIGRP packet types

  7. What does the passive-interface command do when implement with RIP? (Choose two.)

    • Allows an interface to receive routing update traffic
    • Prevents an interface from sending routing update traffic
    • Prevents an interface from sending any normal data traffic
    • Allows an interface to receive normal data traffic
    • Disables a router interface
    • Places a router interface in standby mode
    Explanation:
    The effect of the passive-interface command is dependent on the routing protocol running on the interface. For EIGRP, the router will not only stop sending routing updates, but also hellos, which means that it will not form a neighbor relationship with another EIGRP router on that interface. This is also the case with OSPF and IS-IS. With RIP, however, the router will continue to send hellos even as it stops sending routing updates, and it will still receive routing updates. An example of using the passive-interface command is below. The command is issued from the router configuration mode.

    Router(config-router)# passive-interface ethernet 0/0

    The passive-interface command will even overrule a configuration that includes a distribute list that allows the advertisement of a network through the interface. Examine the partial output of the show run command taken from a router running EIGRP below:

    router6#show run
    !
    router eigrp 100
    network 10.16.18.0 0.0.255.255
    network 10.16.19.0 0.0.255.255
    passive-interface serial 0/0
    distribute-list 50 out serial 0/0
    !
    Access-list 50 permit 10.16.8.0 0.0.255.255

    In this case, although the distribute list allows the advertisement of the 10.16.8.0 network, the passive-interface command applied to the Serial 0/0 interface will disallow all outgoing and incoming updates.

    The passive-interface command does not affect the transmission or reception of normal data traffic, only routing updates.

    The passive-interface command does not disable the router interface. The shutdown command is used to disable a router interface.

    The passive-interface command does not place the router in standby mode.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify loop prevention mechanisms

  8. As the network administrator, you need to develop a verification plan for an OSPF network. The OSPF network has several area routers, area border routers (ABRs), and autonomous system boundary routers (ASBRs).

    Which LSA types should you expect ABRs to generate while verifying the OSPF network? (Choose two.)

    • Type 4
    • Type 3
    • Type 2
    • Type 5
    Explanation:
    ABRs generate Type 3 and Type 4 LSAs in an OSPF network. ABRs are those routers that exist between two OSPF areas, as shown in the following figure:
    300-410 Part 07 Q08 085
    300-410 Part 07 Q08 085

    Type 3 and Type 4 LSAs are generated by ABRs to be flooded into other areas to and from the backbone area (area 0). Type 3 LSAs, or summary link advertisements, contain the list of networks known by one area. ABRs send Type 3 LSAs to the other OSPF areas in a given AS.

    OSPF ABRs generates Type 4 LSAs to advertise the list of routes that point to an ASBR. These LSAs advertise the location of the ASBR.

    Type 5 LSAs are not generated by an ABR. These LSAs are generated by ASBRs to describe routes redistributed into the area from other autonomous systems.

    Type 2 LSAs are not generated by an ABR. A Type 2 LSA is generated only by the designated router (DR) of a segment to be sent to the other routers that belong to the same area as the DR. A DR is a router that has the highest OSPF priority on a segment. These advertisements are used by the DR to represent the routers that are connected to the network.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify network types, area types, and router types

  9. Examine the exhibit.

    300-410 Part 07 Q09 086
    300-410 Part 07 Q09 086

    You have determined that RTR2 is not advertising the CIDR summary address 192.168.0.0 to the other routers in AS 65100.

    Which set of configuration commands will enable the BGP router RTR2 to announce the network prefix 192.168.0.0/16 to the other routers in the AS 65100?

    • router bgp 65100
      neighbor 172.16.1.2 remote-as 65100
      neighbor 192.168.3.2 remote-as 65100
      network 192.168.3.0
    • router bgp 65100
      neighbor 172.16.1.2 remote-as 65101
      neighbor 192.168.3.2 remote-as 65100
      network 192.168.0.0
    • router bgp 65100
      neighbor 172.16.1.2 remote-as 65100
      neighbor 192.168.3.2 remote-as 65100
      network 192.168.0.0 mask 255.255.0.0
      ip route 192.0.0.0 255.0.0.0 null 0
    • router bgp 65100
      neighbor 172.16.1.2 remote-as 65101
      neighbor 192.168.3.2 remote-as 65100
      network 192.168.0.0 mask 255.255.0.0
      ip route 192.168.0.0 255.255.0.0 null 0
    Explanation:
    Issuing the following commands will cause RTR2 to advertise the CIDR block 192.168.0.0/16 to the other routers by using BGP:

    RTR2(config)# router bgp 65100
    RTR2(config-router)# neighbor 172.16.1.2 remote-as 65101
    RTR2(config-router)# neighbor 192.168.3.2 remote-as 65100
    RTR2(config-router)# network 192.168.0.0 mask 255.255.0.0
    RTR2(config-router)# ip route 192.168.0.0 255.255.0.0 null 0

    The network command specifies the address that will be inserted into the BGP table. Without the mask keyword, the classful network will be assumed. Because 255.255.0.0, or /16, is not the natural mask for any Class C address, the mask keyword must also be specified. Thus, 192.168.0.0 and 255.255.0.0 identify the desired address and mask of the 192.168.0.0/16 network prefix.

    The router checks the IP forwarding table for an exact match before it advertises the route. Without a matching entry in the IP forwarding table, that route will not be advertised. RTR2 must be able to advertise a CIDR block and not the individual subnets. A static route is required because BGP requires that a match of the network prefix be present in the forwarding table when using the network command with the mask keyword. Therefore, to ensure an exact match for the identified prefix exists in the IP forwarding table, and to ensure that the prefix will always be advertised, a static route for 192.168.0.0/16 to null 0 is also required.

    The syntax for the network command is shown below:

    network network-number [ mask network-mask ] [ route-map map-tag ]

    The parameters are:
    mask – This parameter is optional and identifies the network or subnetwork to advertise.
    route-map – This parameter is optional and identifies a preconfigured route-map that will be used to filter specific addresses from being advertised.

    The following command set is missing the mask keyword in the network command and the command to create a static route to null 0. The address used in the network command is also incorrect. It should 192.168.0.0:

    router bgp 65100
    neighbor 172.16.1.2 remote-as 65100
    neighbor 192.168.3.2 remote-as 65100
    network 192.168.3.0

    The following command set is missing the mask keyword in the network command and the command to create a static route to null 0:

    router bgp 65100
    neighbor 172.16.1.2 remote-as 65101
    neighbor 192.168.3.2 remote-as 65100
    network 192.168.0.0

    The following command set uses an incorrect mask (255.0.0.0) in the command that creates the static route to null 0. It should be 255.255.0.0:

    router bgp 65100
    neighbor 172.16.1.2 remote-as 65100
    neighbor 192.168.3.2 remote-as 65100
    network 192.168.0.0 mask 255.255.0.0
    ip route 192.0.0.0 255.0.0.0 null 0

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Describe, configure, and verify BGP peer relationships and authentication

  10. Examine the following output.

    300-410 Part 07 Q10 087
    300-410 Part 07 Q10 087

    You are investigating why router RouterA does not include the 172.16.0.0 network in its BGP advertisements. The output contains portions of RouterA’s configuration and IP routing table.

    Which statement correctly identifies the reason why this subnet does not appear in the BGP advertisements?

    • BGP synchronization is enabled by default.
    • The no auto-summary command was used.
    • The 172.16.31.0/24 network was learned through BGP.
    • The 10.1.2.3 IP address was not defined as a BGP neighbor.
    Explanation:
    The no auto-summary command affects how a network identified by using the network command is advertised. The way the router in the exhibit is configured, it will not announce the 172.16.31.0/24 subnet. The BGP router will announce the classful address 172.16.0.0/16 when the routing table, maintained by the IGP, contains an exact match to the network command.

    The network command directly affects what network is advertised in BGP. If the command does not also include a network mask, and if auto-summary is enabled, then the classful address 172.16.0.0 is advertised any time that the router learns about a subnet of 172.16.0.0 via its IGP such as OSPF or EIGRP. The routing table does contain an entry for the 172.16.31.0/24 subnet that was learned through the IGP. However, auto-summary is disabled with the no auto-summary command. Therefore, only networks in the routing table that are an exact match to the network commands are advertised.

    If the configuration goal is to announce the 172.16.0.0/16 network any time one of its subnets is learned, such as 172.16.31.0/24, then you should enable auto-summary. If the goal is to announce only the 172.16.31.0/24 subnet learned through the IGP, then you should alter the network command’s IP address and include the subnet mask.

    The BGP synchronization rule specifies that networks will not be advertised or used via iBGP unless it also has been learned through an IGP. If synchronization is disabled, iGBP will advertise a network without also learning it through an IGP. It does not affect the summarization of routes.

    The 172.16.31.0 network was learned through an IGP session with router 10.1.2.3.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify eBGP (IPv4 and IPv6 address families)

  11. Which method should you use to block all routing updates from being sent into a network through an interface?

    • Static route
    • Default route
    • Passive interface
    • Route-update filtering
    Explanation:
    To stop all outbound routing updates from an interface, you can use the passive-interface command. The effect of the passive-interface command is dependent on the routing protocol running on the interface. For EIGRP, the router will not only stop sending routing updates, but also hellos, which means that it will not form a neighbor relationship with another EIGRP router on that interface. This is also the case with OSPF and IS-IS. With RIP, however, the router will continue to send hellos even as it stops sending routing updates and it will still receive routing updates.

    There are numerous reasons to use the passive-interface command. For instance, suppose that you have a LAN with only end hosts on it and no other router. Additionally, there is no reason to send EIGRP packets, but you want EIGRP to advertise that the network can be reached. The combination of a network statement for that interface plus a passive-interface command would be appropriate.

    Route-update filtering can block all routing updates if you prefer, but it is really intended for selective filtering of updates. If your goal is to block all updates, the passive-interface command is best.

    Default routes and static routes can be used as ways around having to send routing updates out an interface. However, if your goal is to block updates, you should issue the passive-interface command.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Troubleshoot passive interfaces

  12. Which show command displays detailed information about a router’s BGP connections to neighboring routers?

    • show ip bgp
    • show ip bgp summary
    • show ip bgp neighbors
    • show ip bgp connections
    Explanation:
    The show ip bgp neighbors command will show you detailed information about all of the router’s neighbors or peers. A sample of the show ip bgp neighbors output is shown below. The sample utilizes the ip address parameter, which is optional, but can used to limit the output to display information about only one neighbor:
    300-410 Part 07 Q12 088
    300-410 Part 07 Q12 088

    In the above example, router15 has sent out a BGP open packet to the peer at 10.5.1.6 and is listening for a connection request from the peer. This can be determined by the line that says BGP state = Active. It can also be determined that router has established a TCP connection two times, as evidenced by the line Connections established 2.

    The show ip bgp command displays the contents of the BGP routing table. It will not display detailed information about a router’s BGP connections to neighboring routers.

    The show ip bgp summary command displays a summary of the status of BGP connections. It will not display detailed information about a router’s BGP connections to neighboring routers.

    There is no show ip bgp connections command.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Describe, configure, and verify BGP peer relationships and authentication

     

  13. You have configured OSPF on your network and enabled route summarization on an area border router (ABR) with the following command:Router(config-router)# area 3 range 165.164.8.0 255.255.248.0

    What does the 3 specify in this command?

    • The ID of the OSPF backbone
    • The number of networks summarized in the area
    • The ID of the area about which routes will be summarized
    • The ID of the area to which the summary route information will be sent
    Explanation:
    The 3 in the area range command specifies the area that contains the routes that are to be summarized. In OSPF, you can only configure summarization on the border routers. The summaries need to be of routes within a single area. You summarize the routes of an area so that routers in another area do not see the individual networks, just the summary. The correct command syntax is shown below:

    area number range ip-address mask

    The number parameter is the number of the area whose networks are being summarized. For example, in the network shown in the graphic below, to summarize the networks within area 2 to 10.1.0.0/16, you would configure router A with the command area 2 range 10.1.0.0 255.255.0.0. This would not affect the routing tables of the routers within area 2, but instead make the routing tables of areas 0 and 1 smaller. These other routers would only have the summary route listed instead of the individual networks. Router C would only see the summary route 10.1.0.0/16.

    300-410 Part 07 Q13 089
    300-410 Part 07 Q13 089

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify manual and autosummarization with any routing protocol

  14. Which of the following commands is used to verify the link-local, global unicast, and multicast addresses of an IPv6 router?

    • show ipv6 neighbors (only link-local addresses)
    • show ipv6 route
    • show ipv6 protocols
    • show ipv6 interface
    Explanation:
    The show ipv6 interface command is used to verify the link-local, global unicast, and multicast addresses assigned to an IPv6-enabled router interface. The show ipv6 interface command displays information regarding that interface, such as the physical state, MTU, and IPv6 enable/disable state.

    A partial output of the show ipv6 interface command on an IPv6-enabled router named rtrA is as follows:

    300-410 Part 07 Q14 090
    300-410 Part 07 Q14 090

    In the given sample output, you can see that the Fa0/1 interface of rtrA has the link-local address FE80::6339:7BFF:FE5D:A031/64 and the global unicast address 2001:7067:90D1:1::1. The global unicast address is not in EUI-64 format because when the ipv6 address command was issued, the eui64 keyword was not used. If EUI-64 format had been specified with the eui64 keyword, the global unicast address would have been 2001:7067:90D1:1:6339:7BFF:FE5D:A031.

    An IPv6-enabled interface has not only a link-local and global unicast address, but also one or more multicast addresses. A multicast address is an IPv6 address that has the prefix FF00::/8. These addresses are assigned to interfaces of different nodes such that they appear as a logical group. This implies that when a packet is destined for a multicast address, that packet is delivered to all the interfaces that have the same multicast address. The various multicast groups are as follows:
    FF02::1 Indicates the group of all the nodes on the local segment
    FF02::2 Indicates the group of all the routers on the local segment
    FF02::1:FF00:0/104 Indicates a solicited-node multicast group for every unicast or anycast address assigned to the interface

    You can also notice in the sample output that the Fa0/1 interface belongs to three multicast groups: FF02::1, FF02::2, and FF02::1:FF5D:A031. The first two multicast groups refer to the all-host and all-router multicast groups, respectively. The third group, FF02::1:FF5D:A031, is the solicited-node multicast address. This address is created for every unicast or anycast address. A solicited-node multicast address is determined by assigning the least significant 24 bits of the unicast address to the least significant 24 bits of the FF02::1:FF00:0 address.

    The show ipv6 neighbors command displays the link-local /global unicast addresses of the neighbors, including other information such as state and the next-hop interface.

    The show ipv6 route command is used to view the IPv6 routing table on the router. This command displays the prefixes, administrative distance, metric, and next-hop addresses for various IPv6 networks.

    The show ipv6 protocols command is used to view the active routing protocols for IPv6 on the router. This command shows the interfaces, redistribution status, and summarization status about each of the routing protocols enabled on the router.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Identify IPv6 addressing and subnetting

  15. You executed the following commands to assign an IPv6 link-local address to the Fa0/0 interface of the R1 router:R1(config)# interface Fa0/0

    R1(config-if)# ipv6 ospf 1 area 1When you executed the show running-config command on the R1 router, you observed that OSPF for IPv6 is not running on the router.

    Which of the following commands should be added to the interface configuration?

    • ipv6 router ospf
    • ipv6 enable
    • ipv6 ospf neighbor
    • ipv6 ospf cost
    Explanation:
    The ipv6 enable command should be used on R1 to enable IPv6. This command automatically provides an IPv6 link-local unicast address for the interface on which IPv6 is being configured. If an explicit IPv6 address were configured on the interface, the command would not be required.

    The ipv6 router ospf command should not be used in the configuration because this command allows you to enter the router configuration mode for OSPF for IPv6.

    The ipv6 ospf neighbor command is used to configure neighboring routers for OSPF.

    The ipv6 ospf cost command should not be added to the configuration because this command allows you to specify the OSPF cost to send packets from a given interface.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify OSPF for IPv6

  16. Consider the following diagram. All PVCs are active.

    300-410 Part 07 Q16 091
    300-410 Part 07 Q16 091

    If the partial output of the show ip ospf neighbor command executed on Router A is as follows, which of the following statements is TRUE?

    RouterA# show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    1.1.1.1 1 FULL/DROTHER 00:00:13 10.20.10.21 SerialO
    2.2.2.2 1 FULL/DR 00:00:51 10.20.10.22 SerialO

    • Router C and Router B will fail to have all OSPF routes in their tables.
    • All routing tables will be populated correctly.
    • Router A will be the DR.
    • Router C will be the DR.
    Explanation:
    The output of the command shows that Router C and Router B will fail to have all OSPF routes in their tables. In a hub and spoke configuration, as depicted in the diagram, the hub router (Router A) should be the designated router (DR) or the source of updates to the other routers. However, Router B is the DR, as evidenced by the output of the show ip ospf neighbor command executed on Router A.

    This situation could be rectified by setting Routers B and C with a priority of 0, which would disqualify them from being the DR. After that, all routes could be distributed from the hub, which would have visibility of all routes.

    All routing tables will be populated correctly until the hub router is made the DR.

    Neither Router A nor C will be the DR, since it is indicated that Router B is the DR in the output of the command.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify OSPF operations

  17. Which command sets the OSPF priority value of a router interface to 10?

    • Router(config)# ospf priority 10
    • Router(config-if)# ospf priority 10
    • Router(config)# ip ospf priority 10
    • Router(config-if)# ip ospf priority 10
    Explanation:
    The correct syntax for the ip ospf priority command is shown below:

    Router(config-if)# ip ospf priority {number}

    The number is a value from 0 to 255, and 1 is the default priority. A priority value of 0 means that the interface cannot be elected as the designated router (DR) or backup designated router (BDR). The higher the priority, the more preferred the router is when there is an election for DR and BDR for that network.

    NOTE: The ip ospf priority command is entered in interface configuration mode, not router configuration mode.

    All other options either use incorrect syntax or are executed at an incorrect prompt.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify network types, area types, and router types

  18. When configuring a DMVPN solution, which of the following technologies makes it possible for the spoke routers to use dynamic IP addressing?

    • IPsec
    • mGRE
    • NHRP
    • Dynamic routing protocols
    Explanation:
    Next Hop Resolution Protocol (NHRP) allows the spoke routers to register their IP addresses with the NHRP server, which is the hub router. It also allows the spoke routers to then learn the physical IP addresses of the other spoke routers from the hub router, allowing for GRE links to be built dynamically as needed between the spokes. This eliminates the need for the traffic to go through the hub router.

    Dynamic Multipoint VPN (DMVPN) technology leverages the following associated technologies:
    IPsec
    mGRE
    Dynamic routing protocols
    NHRP
    Cisco Express Forwarding

    It makes it possible to build the hub router once, and add spokes later, making no additional changes to the hub. The spokes are able to register with the hub and dynamically build their own connections to other spokes using the IP addresses learned from the hub using NHRP. DMVPN also allows IPsec point-to-point GRE tunnels to be built to new spokes with no IPsec peering configuration. The multipoint GRE technology (mGRE) allows a single physical interface on the hub to be used for all spoke connections.

    Finally, the routing protocols used by DMVPN allow the routers to share routing information, while Cisco Express Forwarding (CEF) is a switching technology that improves performance while reducing the load on the CPUs of the routers.

    Objective:
    VPN Technologies
    Sub-Objective:
    Describe DMVPN (single hub)

  19. You have a DMVPN hub with the following configuration applied:

    300-410 Part 07 Q19 092
    300-410 Part 07 Q19 092

    What problem could occur if the bandwidth 1000 command were missing from the tunnel interface?

    • the tunnel interface will intermittently flap up and down
    • split horizon will prevent routing updates from traversing from spoke to spoke
    • congestion will develop in the tunnel interface
    • the IPsec association will fail
    Explanation:
    In the absence of a bandwidth command on the tunnel interface, the default bandwidth on a tunnel interface is 9 Kbps. EIGRP will use 50% of that (4.5K), which is too low. This will cause problems with the maintenance of EIGRP neighbor relationships. From time to time this will cause the tunnel to flap up and then down as the relationships go up and down. When you execute the bandwidth command it has no real effect on the bandwidth of the link but it will allow EIGRP to use 50% of 10k or 5k for its purposes, leaving 4k for data. This will have little impact on the data while maintaining the neighbor relationships.

    The bandwidth command will have no effect on split horizon. There will be no problems with split horizon, even though the output shows that it has been disabled on the tunnel interface with the no ip split-horizon eigrp 1 command.

    The bandwidth command will not cause congestion on the link. It will only lower the bandwidth available to data from 4.5K to 4K.

    The bandwidth command will not cause the IPsec association to fail. There is sufficient bandwidth for this process.

    Objective:
    VPN Technologies
    Sub-Objective:
    Describe DMVPN (single hub)

  20. The following configuration was applied to the router R66:

    300-410 Part 07 Q20 093
    300-410 Part 07 Q20 093

    What is the interface ID and the IP address of the subinterface created to host the virtual network named red? (Choose two.)

    • FastEthernet1/0/0.3
    • FastEthernet0/0/0.red
    • FastEthernet0/0/3
    • 10.1.1.3
    • 10.1.1.1
    • 10.0.0.3
    Explanation:
    The interface ID of the subinterface created to host the virtual network named red will be FastEthernet1/0/0.3, and the IP address will be 10.1.1.1.

    When a virtual routing and forwarding (VRF) instance is defined, it will have a name and a tag number. The tag number is used by the router to dynamically create a subinterface on the specified physical interface of the EVN trunk. The tag number is appended to the physical interface ID. Since the virtual network (vnet) trunk was defined as FastEthernet1/0/0, the subinterface for vrf red will be FastEthernet1/0/0.3. All subinterfaces on the trunk will use the same IP address as the physical interface defined as the trunk.

    Easy virtual networking (EVN) is a technology that allows for multiple logical networks to use the same physical infrastructure. EVN trunks carry the traffic of multiple VRFs. While the subinterfaces dedicated to each VRF use the same IP address (that of the physical interface of the EVN trunk), no IP address conflicts ever occur because each VRF maintains its own routing and forwarding tables, and while on the trunk, each uses a VRF tag to separate the traffic from each VRF.

    Objective:
    VPN Technologies
    Sub-Objective:
    Describe Easy Virtual Networking (EVN)